Difference between revisions of "Getting started with OpenPSTD v1.1"

From OpenPSTD
Jump to: navigation, search
(Installation)
Line 17: Line 17:
  
 
== Modelling your first scene in OpenPSTD ==
 
== Modelling your first scene in OpenPSTD ==
 +
* Start Blender
 +
* In order to begin modelling the scene clear all objects that appear in the default scene
 +
** First deselect everything by pressing the [De(select) all] item from the [Select] menu
 +
** Click the same item again to select everything
 +
** No click the [Delete...] item from the [Object] menu
 +
:: ''Alternatively with the mouse over the 3D view area, press [A] [A] [X] [Enter]''
 +
:: ''The Blender user interface relies heavily on keyboard shortcuts to allow for efficient modelling.''
 +
:: ''Whenever a key is pressed make sure the mouse is over the relevant area. In this case the large 3d view.''
 +
:: ''Most operations in Blender triggered by the key strokes are also available from the menu items.''
 +
* Navigate to a viewpoint from abive by selecting [Top] from the [View] menu
 +
:: ''Currently OpenPSTD only supports two dimensional scenes.''
 +
* Create a planar mesh by activating [Plane] from the [Add] > [Mesh] menu.
 +
:: ''Alternatively bring up the same menu by clicking [Shift] + [A]''
 +
* Switch to metric display units by clicking on the [Scene] button, the third icon on the button strip, and selecting [Metric]
 +
* Bring up the properties panel by clicking [View] > [Properties]
 +
* Edit the selected planar mesh by entering Edit mode
 +
:: ''Alernatively click the [Tab] button to switch between Object mode and Edit mode''
 +
* Enter Edge select mode by clicking the approppriate button on the toolbar
 +
* Select the rightmost edge by clicking it with the *right* mouse button
 +
* Move the selected edge by *left* clicking the red arrow and typing 8 into the X field that appears on the left
 +
* Now select the rightmost edge and press the [E] button ad press [7] [-] to copy that edge 7 meters to the left
 +
* Now select the topleft edge
 +
:: ''Notice how the extrude operation is different from the move''
 +
* Extrude that selected edge 7 meters
 +
* Now select the two bottom edges by selecting the first and pressing [Shift] while selecting the second
 +
* Move them down 5 meters by pressing [G] [5] [-] [Enter]
 +
* Press [A] to deselect everything and select the two horizontal edges that make up the upper face
 +
* Press [Shift] + [S] to and set the cursor to the center point of the selected edges
 +
* Press [Tab] to exit Edit mode and enter Object mode to have the ability to add additional objects
 +
* Press [Shift] + [A] and add a speaker object to the scene
 +
:: ''Note how the newly created object is positioned at where the cursor is located''
 +
* Add an Empty object by using the same menu
 +
:: ''Any subtype of the Empty object would suffice''
 +
:: ''Blender does not have a dedicated object to designate as a listener, therefore Empty objects are used in OpenPSTD''
 +
* Press [G] and [Shift] + [Z] to move it anywhere in the plane perpendicular to the Z axis
 +
* Now enable the OpenPSTD addon
 +
** Press [Ctrl] + [Alt] + [U] to bring up the User Preferences window
 +
** Under [Addons] search for OpenPSTD and enable it using the checkbox on the right
 +
* On the buttonstrip on the right highlight the first item again
 +
:: ''Note how an OpenPSTD section has been added by enabled the addon''
 +
:: ''The panel can be made wider by draging the border to the left''
 +
* Press the [Simulate with OpenPSTD] button
 +
:: ''Make sure the planar mesh object is selected before pressing the button''
 +
:: ''Notice how after a while areas for the subdomains appear''
 +
:: ''Notice how the light gray area in the bottom area starts to grow over time. This represents the time steps for which a simulation result has been processed.''
 +
* Switch to textured viewport shading to have the sound pressure levels visually display in the 3D view
 +
* Drag around within the light gray area timeline area and notice how the visualisation of sound pressure levels updates accordingly
 +
* Stop the simulation by pressing the button on the OpenPSTD panel on the right
 +
* Select the Empty object designated as the listener
 +
:: ''Notice how a depiction of the Impulse Response is drawn at the timeline area''
 +
* Use the rightmost button below that area to export the Impulse Response as a .wav file

Revision as of 04:38, 3 October 2013

Installation

  1. Install Blender:
    1. Download the appropriate version for your operating system from http://www.blender.org/download/get-blender/.
    2. Follow the installation procecure.
  2. Download the OpenPSTD Blender add-on from (TBD...)
  3. Now run Blender and from the [File] menu select [User Preferences] or click [Ctrl]+[Alt]+[U] to bring it up.
  4. Navigate to the [Addons] section and press the [Install from File...] button at the bottom of the window.
  5. Using the file selection prompt that shows up select the archive downloaded at step 2.

Modelling your first scene in OpenPSTD

  • Start Blender
  • In order to begin modelling the scene clear all objects that appear in the default scene
    • First deselect everything by pressing the [De(select) all] item from the [Select] menu
    • Click the same item again to select everything
    • No click the [Delete...] item from the [Object] menu
Alternatively with the mouse over the 3D view area, press [A] [A] [X] [Enter]
The Blender user interface relies heavily on keyboard shortcuts to allow for efficient modelling.
Whenever a key is pressed make sure the mouse is over the relevant area. In this case the large 3d view.
Most operations in Blender triggered by the key strokes are also available from the menu items.
  • Navigate to a viewpoint from abive by selecting [Top] from the [View] menu
Currently OpenPSTD only supports two dimensional scenes.
  • Create a planar mesh by activating [Plane] from the [Add] > [Mesh] menu.
Alternatively bring up the same menu by clicking [Shift] + [A]
  • Switch to metric display units by clicking on the [Scene] button, the third icon on the button strip, and selecting [Metric]
  • Bring up the properties panel by clicking [View] > [Properties]
  • Edit the selected planar mesh by entering Edit mode
Alernatively click the [Tab] button to switch between Object mode and Edit mode
  • Enter Edge select mode by clicking the approppriate button on the toolbar
  • Select the rightmost edge by clicking it with the *right* mouse button
  • Move the selected edge by *left* clicking the red arrow and typing 8 into the X field that appears on the left
  • Now select the rightmost edge and press the [E] button ad press [7] [-] to copy that edge 7 meters to the left
  • Now select the topleft edge
Notice how the extrude operation is different from the move
  • Extrude that selected edge 7 meters
  • Now select the two bottom edges by selecting the first and pressing [Shift] while selecting the second
  • Move them down 5 meters by pressing [G] [5] [-] [Enter]
  • Press [A] to deselect everything and select the two horizontal edges that make up the upper face
  • Press [Shift] + [S] to and set the cursor to the center point of the selected edges
  • Press [Tab] to exit Edit mode and enter Object mode to have the ability to add additional objects
  • Press [Shift] + [A] and add a speaker object to the scene
Note how the newly created object is positioned at where the cursor is located
  • Add an Empty object by using the same menu
Any subtype of the Empty object would suffice
Blender does not have a dedicated object to designate as a listener, therefore Empty objects are used in OpenPSTD
  • Press [G] and [Shift] + [Z] to move it anywhere in the plane perpendicular to the Z axis
  • Now enable the OpenPSTD addon
    • Press [Ctrl] + [Alt] + [U] to bring up the User Preferences window
    • Under [Addons] search for OpenPSTD and enable it using the checkbox on the right
  • On the buttonstrip on the right highlight the first item again
Note how an OpenPSTD section has been added by enabled the addon
The panel can be made wider by draging the border to the left
  • Press the [Simulate with OpenPSTD] button
Make sure the planar mesh object is selected before pressing the button
Notice how after a while areas for the subdomains appear
Notice how the light gray area in the bottom area starts to grow over time. This represents the time steps for which a simulation result has been processed.
  • Switch to textured viewport shading to have the sound pressure levels visually display in the 3D view
  • Drag around within the light gray area timeline area and notice how the visualisation of sound pressure levels updates accordingly
  • Stop the simulation by pressing the button on the OpenPSTD panel on the right
  • Select the Empty object designated as the listener
Notice how a depiction of the Impulse Response is drawn at the timeline area
  • Use the rightmost button below that area to export the Impulse Response as a .wav file