Difference between revisions of "Getting started with openPSTD v1.0"

From OpenPSTD
Jump to: navigation, search
(Multiple subdomains connected to one edge)
(Boundary Conditions)
Line 76: Line 76:
  
 
==Boundary Conditions==
 
==Boundary Conditions==
 +
MaHo to extend text...
 +
 
==Sources and Receivers==
 
==Sources and Receivers==
 
Move lower left corner to origin
 
Move lower left corner to origin

Revision as of 15:35, 29 August 2014

Contents

Installation

  • Install openPSTD v1.0:
    • Download … Thomas, kan je hier instructies geven?
  • Now run Blender and from the [File] menu select [User Preferences] or click [Ctrl]+[Alt]+[U] to bring it up.
  • Navigate to the [Addons] section and press the [Install from File...] button at the bottom of the window.
  • Using the file selection prompt that shows up select the archive downloaded at step 2. Thomas, kan je dit updaten?
  • Now enable the OpenPSTD addon
    • Press [Ctrl] + [Alt] + [U] to bring up the User Preferences window
    • Under [Addons] search for OpenPSTD and enable it using the checkbox on the right
  • On the buttonstrip on the right highlight the first item again
Note how an OpenPSTD section has been added by enabled the addon
The panel can be made wider by dragging the border to the left

Drawing your first geometry in openPSTD v1.0

Creating the first subdomain

  • Start Blender
  • In order to begin modelling the scene clear all objects that appear in the default scene
    • First deselect everything by pressing the [De(select) all] item from the [Select] menu
    • Click the same item again to select everything
    • Now click the [Delete...] item from the [Object] menu (If you do not see the [Object] menu either in the upper menu bar or in the lower menu bar, move your mouse pointer to the 3D view area and press [Tab] to switch from the Edit to the Object mode).
Alternatively with the mouse over the 3D view area, press [A] [A] [X] [Enter]
The Blender user interface relies heavily on keyboard shortcuts to allow for efficient modelling.
Whenever a key is pressed make sure the mouse is over the relevant area. In this case the large 3D view.
Most operations in Blender triggered by the key strokes are also available from the menu items.
  • Navigate to a viewpoint from above by selecting [Top] from the [View] menu (in the lower left corner of your screen)
openPSTD v1.0 only supports 2D scenes.
  • Create a planar mesh by activating [Plane] from the [Add] > [Mesh] menu.
Alternatively bring up the same menu by clicking [Shift] + [A]
  • Switch to metric display units by clicking on the [Scene] button, the third icon on the button strip, and selecting [Metric]
  • Bring up the properties panel by clicking [View] > [Properties]
  • Move your plane to the origin of the coordinate system by entering the location (x,y,z)=(1,1,0) in the [Location] part of the [Properties] toolbar. This plane is your first subdomain.

Modifying the first subdomain

  • Change the dimensions of your plane using the [Dimensions] part of the [Properties] toolbar
  • Edit the selected planar mesh by entering Edit mode
Alternatively click the [Tab] button to switch between Object mode and Edit mode
  • Now, you can change the dimensions of your plane in the four directions as follows:
    • Enter Edge select mode by clicking the appropriate button on the toolbar
    • Select the rightmost edge by clicking it with the *right* mouse button
    • Move the selected edge by *left* clicking the red arrow and typing 8 into the X field that appears on the left

Adding more subdomains

You can model your geometry by creating more subdomains as follows

  • Select the leftmost edge and press the [E] button ad press [7] [-] [Enter] to copy that edge 7 meters to the left
Notice how the extrude operation is different from the move operation
  • Now select the topleft edge
  • Extrude that selected edge 7 meters by pressing the [E] [Y] [7] [Enter]
  • Now select the two bottom edges by selecting the first and pressing [Shift] while selecting the second
  • Move them down by by *left* clicking the green arrow and typing -5 into the Y field that appears on the left

Multiple subdomains connected to one edge

So far, a geometry has been constructed out of subdomains, where all edges are connected to the two adjacent subdomains. MaHo to extend text...

Boundary Conditions

MaHo to extend text...

Sources and Receivers

Move lower left corner to origin


  • Press [Tab] to exit Edit mode and enter Object mode to have the ability to add additional objects
  • Press [Shift] + [A] and add a speaker object to the scene
Note how the newly created object is positioned at where the cursor is located
  • The location of the speaker can be set by using the [Location] part of the [Properties] toolbar
  • Add an Empty object by using the same menu and define the location by altering the [Location] part of the [Properties] toolbar
Any subtype of the Empty object would suffice
Blender does not have a dedicated object to designate as a listener, therefore Empty objects are used in OpenPSTD

Computational details

Prior to starting the simulation, please take care that the details of the computation are according to your wishes. These details can be found in the openPSTD settings menu in the part of your screen. Explanation on the settings can be found at openPSTD v1.0 settings.

Run a simulation

  • Press the [Simulate with OpenPSTD] button
Make sure that the "Python path" under [Show advanced settings] is setup correctly for the python executable (python.exe on Windows) to be found
Make sure the planar mesh object is selected before pressing the button
Notice how after a while areas for the subdomains appear
Notice how the light gray area in the bottom area starts to grow over time. This represents the time steps for which a simulation result has been processed.
  • Switch to textured viewport shading to have the sound pressure levels visually display in the 3D view
  • Drag around within the light grey area timeline area and notice how the visualisation of sound pressure levels updates accordingly
  • Stop the simulation by pressing the button on the OpenPSTD panel on the right

clear results ...

Exporting results

  • Select the Empty object designated as the listener
Notice how a depiction of the Impulse Response is drawn at the timeline area
  • Use the rightmost button below that area to export the Impulse Response as a .wav file